Zapier Podio need help connecting. JSON issues

I need help creating new items in Monday using information from Podio. My old crm received podio leads via zapier just fine. I have migrated all CRM usage to Monday.

Using the screenshot below is there any issue with the JSON formatting? Is any of this correct at all?

Hi @dfurt!

Responded to you in your appsupport@ email, but happy to include my answer here as well for all future readers.

I spotted 3 little areas to be tweaked:

  1. Super small thing, but I would just make sure to include a space after your colon “:”, just in case!
  2. Because you’re sending the address into a text column, you need to make sure to follow the “text” column formatting. So instead of the "address": followed by the address, make sure to send "text": instead!
  3. For the email column, make sure you’re passing both the email, as well as the text values. So it should look something like this: "{"email": "", "text": ""}" . I see you’re currently missing the “text” field.

Give this a try and let me know if it works!

Great thanks

  • Is there a dedicated Address column in Monday or do addresses go under the text column?

  • In your response you have a comma after", < Do i add this comma in zapier or is this your formatting in your response on the forum?

  • You also have a colon after “text”: < Am I also adding the colon in zap for address & email?

  • The email field needs two podio bubbles? one podio after “email”: " and another podio after “text” : ? I am assuming helen@ will represent my podio input


Hi @dfurt,

Happy to answer your followup questions:

  • Yes, so there is a dedicated Location column, however the formatting that it requires is a bit more specific than a text column. As you can see from this screenshot, it will actually require you to send the address in terms of longitude and latitude coordinates. Based off of the example address you sent, I think it might just be easier to continue working with a Text column.

  • Yes! You would need to manually enter this comma within the relevant Zapier field. This is because you need both the email field, and the text field in order to populate an email column.

  • Yes! You need to send the comma after text, just like you did for email

  • Finally, yes! You would need two podio bubbles of the exact same text. This is because our email column requires you to input two pieces of information, the email that you’re setting, as well as the text for the email you want to set. For instance, let’s say my email is “,” but the text I want to display is “Helen’s email”. Then the value I would be sending would be: "{"email": "", "text": "Helen's email"}"

Let me know if anything is unclear here!


Thank you for following up on this!

I’d love to clarify.

  • Yes, you can use The Location Column on to store addresses. This column will only accept latitude and longitude values via the API/Zapier. For example:

  • Location column with address: {“lat”:“29.9772962”,“lng”:“31.1324955”,“address”:“Giza Pyramid Complex”}

  • The Email column will require you to use 2 values.

  1. “email”: ← this is where you input the actual email for the column;
  2. “text”: ← this is the display text you will see within the board.

To illustrate this further:

For this result, I would need to input the following within Zapier:

{“email":"”,“text”:“can be different than the email”}

So in short, you will need 2 Inputs there, but they can also be the same if that’s more convenient.

I hope this helps!


We made the email field work. The phone and property address do not work. Can you let me know whats going on? I have spent too much time on this ridiculous zapier connection. Not happy about the way this was created. Been on this for days trying to find free time to work with my admin on this. Please let me know whats broken on the phone & address. Ignore the ( )'s those were removed earlier and had no real impact anyway

Hi @dfurt,

Apologies for any and all frustration! I know that this process can be really confusing and difficult, especially for those who perhaps do not have a technical background in coding.

As I mentioned briefly in our email exchange, we do have a new Zapier version coming very, very soon, so that should alleviate many of these difficulties!

For the phone and property address fields, you’re very close. Here are the last few details I would change:

  1. Our Text columns do not require a “key” before the value you’re sending, so you can send the “Property Address” directly, between quotation marks like so: "1. Property Address: 2295....."as stated in our formatting article here: **Text Column** - "Hello world"

  2. For the phone column, I would just send the country flag field anyways, since this will help with how the phone number is ultimately formatted on your board. Try this: {"phone_1" : "Seller Phone: 4101234567", "countryShortName": "US"}. This is the reference from our formatting article: **Phone Column with Country Flag** - {"phone": "5555555555", "countryShortName": "US"}

If the phone column still doesn’t work I suspect that the issue pertains to how the incoming data is being formatted. As such, I would recommend either including another formatting Zapier step in the middle to format the incoming phone number properly, or just utilize a Text column to hold this data. Might save you a lot more time if you go with option #2!

Give these a try and let us know how it goes.

So i need to remove { } from around the values for property address, seller phone & seller email?

Do left side column values need to say text0 & phone_1? they currently just say text and phone. Dev mode shows text0 phone_1. Does that need to go there or on the right side or both sides?

I am not going to use country flag as a workaround. That bothers my OCD. I dont need to create additional columns and then have to deal with them in my way or have to hide them.

We corrected the left and right columns to show text0 and phone_1

do the left and right columns need to match?

after i hear back i will proceed to remove the { }s from the text/address column

Hi @dfurt,

So the formatting must match the formatting in the Zapier article exactly. All curly brackets, quotation marks, commas, all must be followed exactly otherwise it won’t work.

It sounds like it might be helpful to jump on a quick call. Are you free any time today? If so please email into before 6PM EST and I’d be more than happy to walk you through it.

Yes i see the text field is different formatting from the other fields that include { }s
so we currently have the phone number and email working. now working on the address field. will let u know how it goes. the formatting for the phone number looks good so country flag doesnt seem to be necessary unless you have additional feedback on needing country flag. basically the number came in 123 456 7890 which is fine with me. not need (123) 456 1234 unless it blocks me from click to call. will test

1 Like

Everything here is working except for the address/text field. Can you see anything here that needs to be corrected? We removed the keys { } @AlexSavchuk

Hey Daniel, @dfurt

Thanks so much for sticking with us here until this is working as you’d like! I’d love to help out here.

For the text column, you will not need to include a “key” in the values you are sending. Unlike other columns, like Phone and Email, which require a key-value pair (“phone”:“123456789”, which would be the number, and a different key-value pair for the country info - “countryShortName”: “US”}), the Text column will work if you simply enter the text you’d like to appear within quotes. For example:

“Times Square, NYC”

You will only need to speficy a key pair like {“text”:“some text”} for a Long Text column. That said, the new version of our Zapier integration just released should also be a massive help in terms of setting up the values correctly.

I hope this helps - and thank you for your patience, I definitely understand how it can be frustarting to tinker away without getting the end result you are looking for.


Attached newest screenshot

The address still did not come through. I am asking my admin to make sure its textZERO not text letter O. Looks like a zero though

Another problem occurred that can be reversed if needed
the phone number did not come through this time though. Yesterday I asked the admin to format the phone number from 18035552233 to (803) 555-2233 (inside podio app) for my own personal preference. Did this change mess up the phone number field?

Admin confirmed its text0 text zero. Thats what monday needs right? textzero? text0 or the letter O? textO

A property address is short text?

123 Main Street
Columbia, SC 29223

Short or long?

I really need to get this resolved asap. I haven’t heard from you in two days

I need to resolve this issue asap
I trying to get you or helen to respond

I need a consistent back and forth communication to get this resolved

There is an easy solution but its taking days to get consistent support to fix


Sorry you are still having trouble with this. As Helen mentioned earlier, we have now released the new version of our Zapier integration to all users, and it should be much easier to set up what you are looking for there.

To clarify further, if you use any special characters like “-”, or brackets “()” in your phone number value, it will not go through to our servers in the old version. In order to use the newest features in the Zapier integration, you will just need to re-create your app and use the latest integration version.

In terms of the correct column ID to use, it should be “text0” as my best guess here, but without seeing a screenshot of the column ID, it would be hard to tell. The newest Zapier release will handle this one for you, however.

I hope this helps and I’m sorry for the frustrating experience.


none of the following worked using column text or text0

i created another text column to test it out

we used 3 different values on 2 different text columns. 6 test total

the podio property address, the podip last name, and the word “HOT”

nothing worked. This is a monday issue that needs to get fixed

6 text total nothing worked!!! fix this asap


Dan Furtick
Founder & Managing Principal, Upstream Residential