Disable inbox notifications *without* connected board

Hi there all,

My team is using Monday.com quite frequently and we find it very annoying each time we get unrelated notifications in our inbox. Is there any way to disable these?

To make it a bit more specific, we are part of a larger organization, but with our own workspace, team and so on, and we function fully autonomously within this organization. As a result, we don’t really need to get notified about the broader organization in our Monday.com, as it isn’t relevant to us. Only our “branch” is typically of importance.

However, the problem is that we get a lot of these type of inbox messages:

As well as birthday alerts from users within the organization. This is quite annoying as almost every day, someone joins or has a birthday.
I have set the inbox view setting to “I was mentioned”, but it doesn’t seem to make a difference, as these inbox messages are categorised as “Updates without boards”.


Is there any way to disable these?
(I have read all relevant articles on this already, like The Inbox – Support (monday.com) )

Thanks in advance!


As per illustration, one of the notifications of today:

Hi @Rremi

Try going to your notifications and adjusting them. Your can find them by selecting your profile picture in the bottom left corner, select “my profile” , then “notifications”. I am not sure which you need and which you don’t, so you may have to play with them to make the adjustments. Attached is a screenshot of where to find the control.

Thanks for the help Kelley (and pointing me in the right direction)!
I will do some tinkering with it and see what works.

This is also a problem for us. I can’t find any way to disable these, and it’s causing a lot of frustration with our users.

Hi @kmcdaniel - have you tried the individual notifications in “My Profile” to see if that will limit the number of email notifications?

I’m not talking about email notifications - I mean the monday notifications. It’s difficult to wade through a list of birthdays for 1000+ employees when you’re trying to find your @mentions.