Docusign app integration Error

I signed up for Docusign Business Pro plan so I can integrate with Monday. I downloaded the Docusign app and during the integration, I got this error {“error”: “Session Not Identified”}

What I tried so far to fix this:
1- clear cache
2- Safari private browser
3- chrome regular and incognito mode
4- restarted computer

Nothing works. I have the correct Business Pro plan as needed per Docusign. Anyone found a fix for this? I saw back in 2022, some people had the same issues and it wasn’t marked as resolved. There were no solutions.

hey, i can relate, really
tech glitches can be so frustrating, from what you’ve tried, it sounds like u’ve covered some of the basics. clearing cache, trying different browsers, and even restarting ur pc are good trobleshooting steps. but it’s a bit strange that the issue persists. since u’ve already checked your docusign plan, that’s a good start. but it might still be worth to check if everything’s set up correctly on the docusign side

I received a reply from Docusign…basically they’re saying they did not do that app on Monday.com and I should reach out to Monday.com instead. Monday is bouncing me to Docusign, Docusign bouncing me back to Monday.

What do I do now?

Hi @Khanh82 :wave:

Try these guys - apps@moveoboost.com
That’s the developer as far as I can tell.

Hope it helps!
peta@upstreamtech.io :slight_smile:

Thanks, I’ll email them and report back if there’s a solution.

In the marketplace:
image

So whether or not DocuSign support acknowledges it - they or their subcontractor developed it. I assume you contacted their support via the contact support from the app listing?

@Matias.Monday just pinging you here in case you might be able to help sort out who is responsible for supporting this app. I assume its docusign as its not a first party integration.

I’m struggling with this App too…it would be such a time saver if I could get it to work. One thing I did find out is that you do have to be an administrator on your DocuSign account in order to integrate it. I don’t have that level of permissions on our DocuSign account, so I was wondering if that was why I was getting the session error (I’m getting the same one you are). I was going to have our Admin try to do the install, but I’ve ran into some hurdles where our security team is requiring more documentation on the integration before we can move forward. I’m trying to get that now from the developer. If I’m able to move forward and have any luck I’ll let you know!

We’re also encountering the same issue. Have anyone found any solutions? Thanks

@igaranin @jbradford Check out monday docusign integration alternative - GetSign showcasing seamless integration to monday boards for merging sub items, mirrored columns and formulas into your templates and with the fraction of the cost.