Connecting Item Board With Subitems Board - Get information from The parent item to the Subitem

CANVIew

Yesterday I was able to set up connections between the parent item and the subitems. I was able to mirror columns from the item to the subitems.
I set up different formulas and functionalities based on this.

Today I’m not able to connect the item to the subitems any more. Trying to connect the two boards (Subitems and Items) just isn’t available anymore.

Any thoughts on why is this happening? Did Monday.com changed anything on the features we can use? This is demotivating.

How do I reconnect the two boards again?

Thanks!

@LucasG,

I’m not sure what might have changed. But, there should be no reason to add a connect boards column to a board to connect items to subitems… Actually, I suppose you might want to connect only some of the subitems. In any case, you should be able to add a mirror column to the main board that references the subitems without using a connect boards column.

If that is not working for you, I would recommend contacting monday support at support@monday.com.

Jim

Hi @JCorrell, I want to connect all of the subitems to the item. Only by doing this, can I mirror information from the item into the subitems.
In fact, I want to do the exact opposite of what you’re suggesting. Again, in your words, I want to add a mirror to the subitems, that references the item.

I did contact support. I know September is a busy month!, I hope we can solve it soon.

Thank you for your comment!

@LucasG,

You’re use case makes sense. It would be great if the item-to-subitems link went both ways. But, as you are aware, it currently does not.

Please let us know if/how your issue gets resolved.

Yes it’s strange, that I got it to work (you can see it in action in the GIF) and in the following day the connection broke and I wasn’t able to repeat it.
I’ll have to do it through Integromat via Webhooks. It’s a way but not the most convenient one.

Well, this would be so simple to solve. If someone at Monday.com dev team saw this it shouldn’t take them longer than 2 minutes to implement the solution. You only need to show the Items’ Board when the “Choose Boards to connect” popup appears while trying the “Connect Boards” column type.

Here I made a Middle Board. So I’m Mirroring from the Item level to a different Board, then from the subitem level, I connecto to the item level at the Middle Board and Mirror a Column, and it works. Having to do this work around is quite annoying…

Item to Subitems2

what do you think? @JCorrell

@LucasG,

It’s great that you were able to get it working again. But, the 3rd board should not be necessary. I don’t know why you are having an issue. Hopefully, monday support will be able to come back with the resolution soon.

I did test structure on my account and was able to get it to work without any issues. After testing, the only thought I had about what might be wrong is that when you create the connect boards column, it is best to make sure to check the “Create a two-way connection” box to create the second connect boards column. If you don’t, the columns will not automatically sync. It is also important to note that these two-way connections are updated asynchronously, that is, it can take some time for the second connect boards column to get updated. Depending on how busy the servers are, this can, in some cases take minutes.

Jim

1 Like

Sensational!> Did you get it to work in the same Board right? or connecting to a different board? I’m eager to see it working. If you happen to have a screenshot of it, it would be great to see it.

@LucasG,

Same board, two-way connect boards columns. I linked the item to the subitems manually. But that shouldn’t matter. I’ve deleted them after testing. Is there something in particular that you want to see?

I wonder how you chose the board to link them. It doesn’t appear to me in the options of the different boards to choose from in order to connect them.

@LucasG,

1 Like

Thank you Jim!. That gave me hopes that we’ll get it working soon.
Sill for us, when I try to Choose the Boards to Connect, the Subitems Boards never appear.

It must be something with the EU servers, or with permissions for our organization to use certain features then.

Nobody from Monday.com has given us an answer yet, sadly.

Thank you!

@LucasG,

Just a thought… do you have any unusual columns in the subitems? Like other connect boards columns or columns with restricted permissions?

Jim

Nothing special.
I even tried in a different test account, that I just opened to make the test, in another browser, with the simplest possible Board, and it didn’t work there either.

HI @dipro! Have you seen this before somewhere else?!

Hey @LucasG – I think it’ll be best if we try and solve this over a support ticket/email.

Can you please shoot an email to support@monday.com with a description of what’s occurring, and what the expected behaviour is? I’d advise you include a link to this community thread, so our team has the full context.

We’ll take it from there – cheers! :crystal_ball:

1 Like

@dipro @JCorrell

I wanted to give you an update on this issue…
This is what I was told from support@monday.com:

Hi Lucas,

Thanks for your patience.

I’ve received a response from the devs! I’m sorry to be the bearer of bad news, unfortunately, they have confirmed that this feature won’t be coming back and cannot be reactivated, this is because it was written out of our platform as it was extremely buggy.

I have inquired to determine whether it is possible to be re-added, unfortunately, they cannot add it to accounts. …

Thank you for your time here!

Lucas

@dipro @JCorrell

New Message incoming!

We have a new update from our devs and they are now working on a fix of this issue so that you can connect the subitems to their parent item.

Much better now.

yay-yes

1 Like

@LucasG,

Don’t see a lot of GIF game here. I like it! … and that’s good to hear.

1 Like

I’ve got a new update on the subject.

The fix is up! You can now connect sub-items to their parent items (but cannot connect the parent item to itself, we’re still working on the best solution there.

I tried it and it’s working now. :upside_down_face:

Thanks!!

1 Like